Plugin PixelColor

Postez ici vos propositions d'amélioration
xan2622
Messages : 173
Enregistré le : 11 avr. 2014, 18:15

Re: Plugin PixelColor

Message par xan2622 » 22 avr. 2014, 16:43


MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 23 avr. 2014, 00:55

Merci xan2622 pour les informations sur https://github.com/aadamfr/Super_macro/issues/10.

Je rappelle que je fonctionne sous Windows 7 (Edition intégrale), voici quelques nouvelles remarques :

A ce lien : http://adam.denadai.free.fr/SM_HTML/index.php
sous la case bleue "Télécharger", il est indiqué "Version 3.1.0.47 • Windows • 4.17 Mo"
le setup.exe téléchargé correspond à une taille 4 267 391 octets, sur disque 4 268 032 octets
Son exécution pour l'installation affiche le message :
"Cet assistant va vous guider dans l'installation de Super macro version 3.1.0.46 sur votre ordinateur"
Ce n'est pas conforme à l'information sur la page de téléchargement indiquant une version 3.1.0.47

Si je me laisse guider, l'installation se fait sur le répertoire : "C:\Program Files (x86)\Super macro"
A la fin de l'installation l'exécution de Super Macro produit une succession d'erreurs (Exception EInOutError dans le module... Accès au fichier refusé).
Je désinstalle donc et je recommence, cette fois en précisant le nom du répertoire en remplaçant l'espace par un underscore (tiret bas) soit : "C:\Program Files (x86)\Super_macro", puis l'installation et l’exécution de Super Macro se produisent sans erreur.

Je compare les propriétés du fichier Super_macro.exe avec les anciennes, il y a une différence :
Pour celui récemment téléchargé : 2 265 600 octets, modifié le jeudi ‎27 ‎février ‎2014, ‏‎15:21:18
Pour l'ancien que j'avais téléchargé : 2 265 088 octets, ‎modifié le vendredi ‎4 ‎juin ‎2010, ‏‎11:32:40
Cependant l'exécution de TEST.mcr pour le plugin PixelColor produit le même résultat, la couleur demeurant en permanence à 255255255.
Modifié en dernier par MEZANGUEL le 23 avr. 2014, 13:39, modifié 1 fois.

Avatar du membre
Feitan
Site Admin
Messages : 300
Enregistré le : 11 avr. 2014, 15:15

Re: Plugin PixelColor

Message par Feitan » 23 avr. 2014, 10:27

Hello, j'ai testé le test.mcr effectivement il sort la valeur de 255255255 mais c'est parceque l'interface de supermacro (et les boutons) ont beaucoup de blanc. Teste d'une autre façon je suis quasi sur que ça fonctionne

MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 23 avr. 2014, 13:56

J’ai répondu à cette question en postant un peu plus haut avec cet exemple, ma souris était bien dans le rouge :

Image

Je vois défiler les coordonnées X, Y de ma souris partout où je la déplace sur l’écran, y compris sur autre chose que du blanc, les deux coordonnées s'affichent bien en rapport avec ses mouvements, mais la variable couleur reste à 255255255, quelle que soit la couleur survolée.

Avatar du membre
Feitan
Site Admin
Messages : 300
Enregistré le : 11 avr. 2014, 15:15

Re: Plugin PixelColor

Message par Feitan » 23 avr. 2014, 16:06

La valeur de 1166 me parait un peu grande pour etre sur le coté gauche de ton écran, c'est quoi ta résolution?

MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 23 avr. 2014, 20:16

Ma résolution est 1920x1080.

J'ai recommencé cet exercice sur l'autre ordinateur, résolution 1280x1024, avec la souris bien à gauche (X = 20) :

Image

Le problème sur mon ordinateur venait du choix du thème d'arrière-plan du bureau : clic droit sur le bureau, Personnaliser (tout en bas). Le thème sélectionné doit l'être parmi un des thèmes "Aero" et non un des thèmes "de base et à contraste élevé", et le plugin PixelColor pour détecter la couleur fonctionne sinon il ne fonctionne pas. Il est très facile de passer d'un thème à l'autre et de vérifier ce dysfonctionnement. L'autre ordinateur doit être dans le même cas, je vérifierai cela demain... chose faite, c’était bien ça.

Le choix du thème Aéro en arrière-plan du bureau semble débloquer d’autres situations : http://www.youtube.com/watch?v=tWe-95r3DzE

Je réitère mes deux remarques en haut de page, signalant anomalies lors de l'installation sous windows 7 :

  • A ce lien : http://adam.denadai.free.fr/SM_HTML/index.php
    sous la case bleue "Télécharger", il est indiqué "Version 3.1.0.47 • Windows • 4.17 Mo"
    le setup.exe téléchargé correspond à une taille 4 267 391 octets, sur disque 4 268 032 octets
    Son exécution pour l'installation affiche le message :
    "Cet assistant va vous guider dans l'installation de Super macro version 3.1.0.46 sur votre ordinateur"
    Ce n'est pas conforme à l'information sur la page de téléchargement indiquant une version 3.1.0.47

    Si je me laisse guider, l'installation se fait sur le répertoire : "C:\Program Files (x86)\Super macro"
    A la fin de l'installation l'exécution de Super Macro produit une succession d'erreurs (Exception EInOutError dans le module... Accès au fichier refusé).
    Je désinstalle donc et je recommence, cette fois en précisant le nom du répertoire en remplaçant l'espace par un underscore (tiret bas) soit : "C:\Program Files (x86)\Super_macro", puis l'installation et l’exécution de Super Macro se produisent sans erreur.
Modifié en dernier par MEZANGUEL le 24 avr. 2014, 19:25, modifié 3 fois.

Avatar du membre
Feitan
Site Admin
Messages : 300
Enregistré le : 11 avr. 2014, 15:15

Re: Plugin PixelColor

Message par Feitan » 23 avr. 2014, 21:38

Bon. Heureux que ça fonctionne alors ! Le bug parait pas hyper logique mais tant qu'on a une solution simple c'est nickel ;)

MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 23 avr. 2014, 21:40

Oui tout à fait, qu'on se le dise - Merci.

Répondre