Plugin PixelColor

Postez ici vos propositions d'amélioration
MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Plugin PixelColor

Message par MEZANGUEL » 20 avr. 2014, 18:09

Bonjour,

Merci à l'auteur pour la création de SuperMacro.

Concernant le plugin PixelColor, sous Windows 7 la couleur des pixels est toujours à 255255255 (du blanc : http://fr.wikipedia.org/wiki/Aide:Couleurs), ce dll pour Windows XP semble ne pas fonctionner pour Windows 7. Merci beaucoup si vous aviez un lien pour télécharger un plugin adapté, la fonction PixelColor est une fonction graphique basique indispensable.

Ayant téléchargé cette version PixelColor.zip - Taille 39,9 Ko (40 917 octets) - Sur disque 40,0 Ko (40 960 octets)

Cordialement.

xan2622
Messages : 173
Enregistré le : 11 avr. 2014, 18:15

Re: Plugin PixelColor

Message par xan2622 » 20 avr. 2014, 18:21

C'est étrange. J'étais avant sous Windows 7 et je n'ai jamais eu aucun problème (ni même n'ai-je entendu parler de soucis similaires d'autres utilisateurs).

MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 20 avr. 2014, 19:03

Cela avait déjà été évoqué, il y a plus de six mois :
http://webcache.googleusercontent.com/s ... clnk&gl=fr

Avatar du membre
Feitan
Site Admin
Messages : 300
Enregistré le : 11 avr. 2014, 15:15

Re: Plugin PixelColor

Message par Feitan » 21 avr. 2014, 09:23

Salut !

Je tourne avec la version 3.1.0.46 de Supermacro et aucun problème pour le pixel color :

Image

MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 21 avr. 2014, 13:10

Merci pour cet exemple, est t'il réalisé sous Windows Vista ?

Avec SuperMacro sous onglet Aide, A propos...
J'obtiens les informations suivantes :
  • Dernière mise à jour : 28/01/10
    Version : 3.1.0.46
    Windows version : Windows Vista
    Internet Explorer Version : 9.11.9600.17041
Je ne fonctionne pas avec Windows Vista, mais avec Windows 7.
Je viens de mettre à jour le pilote de ma carte graphique Nvidia GeForce GTX 580 version 335.23
L'exemple TEST.mcr fourni avec PixelColor fonctionne bien pour les positions de la souris, mais la variable Couleur demeure à 255255255 :

Image

Avatar du membre
Feitan
Site Admin
Messages : 300
Enregistré le : 11 avr. 2014, 15:15

Re: Plugin PixelColor

Message par Feitan » 21 avr. 2014, 20:24

Non non j'ai Windows 7 64 bit (sinon je me serais pas permis de poster ! :) )

MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 21 avr. 2014, 21:14

Ok merci bien, si je trouve une explication je reviendrais la donner ici.

Avatar du membre
Feitan
Site Admin
Messages : 300
Enregistré le : 11 avr. 2014, 15:15

Re: Plugin PixelColor

Message par Feitan » 21 avr. 2014, 23:19

Envoi une image de ta page de test pour voir ou regarde en reprenant une image comme la mienne pour voir.

MEZANGUEL
Messages : 10
Enregistré le : 20 avr. 2014, 16:29

Re: Plugin PixelColor

Message par MEZANGUEL » 22 avr. 2014, 12:43

J’ai utilisé un autre ordinateur sous Windows 7 en dehors de chez moi, et je suis confronté au même problème.

La discussion sur ce problème :
http://webcache.googleusercontent.com/s ... clnk&gl=fr)
datant du 06-10-2013, s’il a été résolu une éventuelle mise à jour du fichier PixelColor.dll pourrait exister au-delà de cette date, peux-tu m’indiquer les caractéristiques de ton fichier PixelColor.dll ?
Celles du mien sont : Taille 73216, sur disque 73728 Créé le : mercredi 18/01/2012 14 :19:04 (toujours téléchargeable sur cette page : http://adam.denadai.free.fr/index.php?page=Plugins)

Sur le net j’ai trouvé une discussion sur un problème de captation de la couleur d’un pixel, renvoyant toujours 255,255,255 quelle que soit la couleur survolée, mettant en cause la syntaxe wxPaintDC :
http://www.developpez.net/forums/d13541 ... leur-glop/
(wxPaintDC : http://wiki.wxwidgets.org/WxPaintDC)
Mais a priori non, selon la syntaxe qui prend la couleur dans le code source :
(http://adam.denadai.free.fr/SM_HTML/plugin.php)

Code : Tout sélectionner

color := GetPixel(Dc, X, Y);
  r := color and $FF;
  g := (color shr 8) and $FF;
  b := (color shr 16) and $FF;
  value := format('%.3d%.3d%.3d',[r,g,b]);
SetValueOfVar(Pchar(GetParam(3)),Pchar(value));

end;
…
…
...
begin
DC := GetWindowDC(GetDesktopWindow);
end.
Modifié en dernier par MEZANGUEL le 22 avr. 2014, 18:05, modifié 2 fois.

Avatar du membre
Feitan
Site Admin
Messages : 300
Enregistré le : 11 avr. 2014, 15:15

Re: Plugin PixelColor

Message par Feitan » 22 avr. 2014, 14:04

J'ai exactement le même pixel color que toi.. Bizarre parceque je fais pas mal de test avec PixelColor du coup et ça bug pas du tout (en fait je vérifie pas la couleur qui sort mais du moment que j'ai une valeur qui sort c'est utilisable)

Répondre